Article successfully added.
Budget Scrub Trousers

Budget Scrub Trousers

€9.99incl. VAT

Colour

Trouser size

  • BS002

Budget Scrub Trousers are great for using in any medical environment because they are inexpensive, lightweight and super comfy. These medical scrubs are the traditional go to scrubs for every hospital in the country, These hospital scrubs are available in a variety of colours in sizes petite, small, big & tall.

PLEASE NOTE UNISEX SIZES CAN RUN LARGE. REFER TO SIZE GUIDE BELOW TO FIND YOUR PERFECT FIT.

Read, write and discuss reviews... more
Customer review for "Budget Scrub Trousers"
6 Jun 2019

Review

Hi they are way too big, but that's my own fault,as I ordered the wrong size .I ordered my usual size in an ordinary pants. I didn't have time to send them back so busy.actually a darker shade of wine is what I'm looking for.Thank you .

[originally posted 23/07/2015]

19 Mar 2019

Review

Great product, high quality, unbelievably fast delivery!

[originally posted 24/07/2015]

Write a review
Ratings will be activated after verification.

The fields marked with * are required.

Budget Scrub Trousers are great for using in any medical environment because they are inexpensive, lightweight and super comfy. These medical scrubs are the traditional go to scrubs for every hospital in the country, These hospital scrubs are available in a variety of colours in sizes petite, small, big & tall.

PLEASE NOTE UNISEX SIZES CAN RUN LARGE. REFER TO SIZE GUIDE BELOW TO FIND YOUR PERFECT FIT.

Customer review for "Budget Scrub Trousers"
6 Jun 2019

Review

Hi they are way too big, but that's my own fault,as I ordered the wrong size .I ordered my usual size in an ordinary pants. I didn't have time to send them back so busy.actually a darker shade of wine is what I'm looking for.Thank you .

[originally posted 23/07/2015]

19 Mar 2019

Review

Great product, high quality, unbelievably fast delivery!

[originally posted 24/07/2015]

Write a review
Ratings will be activated after verification.

The fields marked with * are required.

BUNDLE
BUNDLE
BUNDLE